هک‌ها و تشعشعات وجدان آزاد

نوشته‌های سیدمحمدمسعود صدرنژاد

ابزار کاربر

ابزار سایت


ioncube

اگر نسخه ۶۴ بیت گنو/لینوکس استفاده می‌کنید فایل زیر را دانلود کنید و از حالت فشرده خارج کنید:

wget http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz
tar xvfz ioncube_loaders_lin_x86-64.tar.gz

اگر از نسخه ۳۲ بیت استفاده می‌کنید:

wget http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz
tar xvfz ioncube_loaders_lin_x86.tar.gz

در دایرکتوری لودر یک سری فایل .so وجود دارد که برای ورژن‌های مختلف لودر هست. ورژن لودری که نیاز دارید را پیدا کنید و در دایرکتوری ماژول‌های PHP کپی کنید. برای پیدا کردن محل این دایرکتوری دستور زیر را وارد کنید:

php -i | grep extension_dir

خروجی دستور چیزی شبیه این خواهد بود:

extension_dir => /usr/lib/php5/20121212 => /usr/lib/php5/20121212

آدرس افزونه را باید در php.ini وارد کنید. برای این منظور ابتدا محل php.ini را پیدا کنید:

locate php.ini

سپس آدرس فایل .so را در متن زیر جایگذاری و در آن کپی کنید:

zend_extension = /usr/lib/php5/20121212/ioncube_loader_lin_5.5.so

فایل مذکور را در دایرکتوری مشخص شده کپی کنید و بعد آپاچی را ریست کنید. اگر از php-fpm استفاده می‌کنید باید آن را هم ریست کنید:

service apache2 restart
service php5-fpm restart
ioncube.txt · آخرین ویرایش: 2019/07/17 17:03 (ویرایش خارجی)